Quantcast
Viewing latest article 6
Browse Latest Browse All 10

Network Statements, Part 6

Let’s look at some additional options that can be used with EIGRP network statements. Refer to Figure 1:

Image may be NSFW.
Clik here to view.

In order to get EIGRP running on all interfaces, we could do this:

router eigrp 1

network 192.168.1.0
network 172.16.0.0
network 10.0.0.0

As a result, the interfaces would advertise the following prefixes (remember that automatic route summarization is enabled for EIGRP by default):

  • Fa0/0 – 10.0.0.0/8 and 172.16.0.0/16
  • Fa0/1 – 10.1.1.0/24, 172.16.0.0/16 and 192.168.1.0/24
  • Fa0/2 – 10.0.0.0/8 and 192.168.1.0/24
  • Fa0/3 – 10.2.2.0/28, 172.16.0.0/16 and 192.168.1.0/24

Suppose that we want to get EIGRP running on all interfaces except Fa0/3. How could we accomplish this? One option would be to use the “passive-interface” command under EIGRP:

router eigrp 1

network 192.168.1.0
network 172.16.0.0
network 10.0.0.0
passive-interface fastethernet0/3

If we did, the result would be that the following prefixes would be advertised:

  • Fa0/0 – 10.0.0.0/8 and 172.16.0.0/16
  • Fa0/1 – 10.1.1.0/24, 172.16.0.0/16 and 192.168.1.0/24
  • Fa0/2 – 10.0.0.0/8 and 192.168.1.0/24
  • Fa0/3 – No EIGRP packets sent

Another option is to use a wildcard mask on the EIGRP network statement. Remember that when using a wildcard mask, a “0” in a mask bit position means match the corresponding address bit, and a “1” in a mask bit position means ignore it:

router eigrp 1

network 192.168.1.0
network 172.16.0.0
network 10.2.2.0 0.0.0.255

Thus, we’re running EIGRP on Fa0/1, but not on Fa0/3, and the advertisements would be:

  • Fa0/0 – 10.0.0.0/8 and 172.16.0.0/16
  • Fa0/1 – 172.16.0.0/16 and 192.168.1.0/24
  • Fa0/2 – 10.0.0.0/8 and 192.168.1.0/24
  • Fa0/3 – No EIGRP packets sent

Note that the effect obtained with “passive” is not the same as what we get by using the wildcard mask, in that the 10.1.1.0/24 subnet (which is on Fa0/3) is not advertised if it’s not covered by a network statement. Remember that if we cover the interface with a network statement, the router will inject the subnet of the interface into the routing protocol, and if we don’t, it won’t (unless we use “redistribute connected”).

Another use of the wildcard mask is to get EIGRP running on all interfaces, like this:

router eigrp 1

network 0.0.0.0 255.255.255.255

With this mask, we’re telling EIGRP to ignore all of the address bits, and run the protocol on any interface (or subinterface) with an IP address).

Next time, we’ll take a look at OSPF network statements.

Author: Al Friebe


Viewing latest article 6
Browse Latest Browse All 10

Trending Articles